XPS 13 9350 – 16.10 and Broadcom (DW 1820A) woes (with Intel 8260NGW fix!)

After upgrading to 16.10, when I would resume from sleep my xps 13 would reconnect to my network but not have any DNS (it had a connection, but couldn’t navigate to sites by name, IP addresses worked). I was able to issue a

sudo systemctl restart network-manager

And this generally brought the network back online properly .. but I was noticing my speed was TERRIBLE.

I generally had great luck with my xps13 9350 with the broadcom wireless card (DW 1820A), although had read even the great Linus himself said his luck was terrible and he replaced it with an intel card. With 16.10 coming about and causing issues I decided to take the (small – approx $25) plunge and replace the card.

I bought this intel 8260NGW 3rd generation wifi card and hoped everything would work out, it sure has!!

First, taking the screws out of the laptop was a complete PITA. There are VERY small torx screws on the bottom of the laptop, luckily a small flathead jewelers screwdriver did the job … although I’d recommend something to help you grip since you need to torque the screwdriver quite a bit to get the screws to turn.

PLEASE NOTE! Be very careful with your very expensive laptop. There’s nothing COMPLICATED about removing the back of the laptop, but be gentle. When you get the screws out, you’ll want to get something in between the frame and the metal panel, use something plastic (not metal, which will scrape), and once you have some leverage the entire back will pop off with a little pressure. There’s no connections on the back panel that will be pulled.

With my handy rubber grip and screwdriver I removed the back of the laptop and could then remove the broadcom wifi adapter.

I carefully pried the 2 antenna connections off the old card, put in the new card, and carefully applied pressure to the antenna connections to reset them. BE CAREFUL HERE!! You don’t want to ‘pop’ something with such small electronics.

Once I plugged in the new card and snapped the back of the laptop back on … I fired up 16.10 and was greeted with mega fast speed (866 Mb/s)!

Yay intel. 🙂